$re = '/^((.*?) *\((\d+)\))(?: *\{((.*?) *\((.+?)\)) *\})?/m';
$str = '"!?Text" (1234)
"#1 Text" (1234)
#2 Text (1234) {Some text (#1.1)}
Text (1234)
Some Other Text: More Text here 1234-4321 (1234) (V)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);