// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^((.*?) *\((\d+)\))(?: *\{((.*?) *\((.+?)\)) *\})?").unwrap();
let string = "\"!?Text\" (1234)
\"#1 Text\" (1234)
#2 Text (1234) {Some text (#1.1)}
Text (1234)
Some Other Text: More Text here 1234-4321 (1234) (V)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}