import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((.*?) *\\((\\d+)\\))(?: *\\{((.*?) *\\((.+?)\\)) *\\})?";
final String string = "\"!?Text\" (1234)\n"
+ "\"#1 Text\" (1234)\n"
+ "#2 Text (1234) {Some text (#1.1)}\n"
+ "Text (1234)\n"
+ "Some Other Text: More Text here 1234-4321 (1234) (V)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}