import re
regex = re.compile(r"^((.*?) *\((\d+)\))(?: *\{((.*?) *\((.+?)\)) *\})?", flags=re.MULTILINE)
test_str = ("\"!?Text\" (1234)\n"
"\"#1 Text\" (1234)\n"
"#2 Text (1234) {Some text (#1.1)}\n"
"Text (1234)\n"
"Some Other Text: More Text here 1234-4321 (1234) (V)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")