package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((.*?) *\((\d+)\))(?: *\{((.*?) *\((.+?)\)) *\})?`)
var str = `"!?Text" (1234)
"#1 Text" (1234)
#2 Text (1234) {Some text (#1.1)}
Text (1234)
Some Other Text: More Text here 1234-4321 (1234) (V)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}