using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((.*?) *\((\d+)\))(?: *\{((.*?) *\((.+?)\)) *\})?";
string input = @"""!?Text"" (1234)
""#1 Text"" (1234)
#2 Text (1234) {Some text (#1.1)}
Text (1234)
Some Other Text: More Text here 1234-4321 (1234) (V)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}