#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<p>[^*?]<a.*?href=.*?javascript:window.history.back.*?>[^*?].*?<\/a>[^*?]<\/p>"
Local $sString = "<p>" & @CRLF & _
"<sdfsdfsfsfsfsfs>" & @CRLF & _
"sdfsdfsdf<ssfssfsdf>" & @CRLF & _
"<a href="javascript:window.history.back();">Document selection</a></p>" & @CRLF & _
"<p><a href="http://www.scei.co.jp/legal/">Country / Region selection</a></p>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")