package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<p>[^*?]<a.*?href=.*?javascript:window.history.back.*?>[^*?].*?<\/a>[^*?]<\/p>`)
var str = `<p>
<sdfsdfsfsfsfsfs>
sdfsdfsdf<ssfssfsdf>
<a href="javascript:window.history.back();">Document selection</a></p>
<p><a href="http://www.scei.co.jp/legal/">Country / Region selection</a></p>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}