$re = '/<p>[^*?]<a.*?href=.*?javascript:window.history.back.*?>[^*?].*?<\/a>[^*?]<\/p>/';
$str = '<p>
<sdfsdfsfsfsfsfs>
sdfsdfsdf<ssfssfsdf>
<a href="javascript:window.history.back();">Document selection</a></p>
<p><a href="http://www.scei.co.jp/legal/">Country / Region selection</a></p>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);