import Foundation
let pattern = #"<p>[^*?]<a.*?href=.*?javascript:window.history.back.*?>[^*?].*?<\/a>[^*?]<\/p>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<p>
<sdfsdfsfsfsfsfs>
sdfsdfsdf<ssfssfsdf>
<a href="javascript:window.history.back();">Document selection</a></p>
<p><a href="http://www.scei.co.jp/legal/">Country / Region selection</a></p>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)