// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<p>[^*?]<a.*?href=.*?javascript:window.history.back.*?>[^*?].*?<\/a>[^*?]<\/p>").unwrap();
let string = "<p>
<sdfsdfsfsfsfsfs>
sdfsdfsdf<ssfssfsdf>
<a href=\"javascript:window.history.back();\">Document selection</a></p>
<p><a href=\"http://www.scei.co.jp/legal/\">Country / Region selection</a></p>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}