re = /<p>[^*?]<a.*?href=.*?javascript:window.history.back.*?>[^*?].*?<\/a>[^*?]<\/p>/
str = '<p>
<sdfsdfsfsfsfsfs>
sdfsdfsdf<ssfssfsdf>
<a href="javascript:window.history.back();">Document selection</a></p>
<p><a href="http://www.scei.co.jp/legal/">Country / Region selection</a></p>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end