import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<p>[^*?]<a.*?href=.*?javascript:window.history.back.*?>[^*?].*?<\\/a>[^*?]<\\/p>";
final String string = "<p>\n"
+ "<sdfsdfsfsfsfsfs>\n"
+ "sdfsdfsdf<ssfssfsdf>\n"
+ "<a href=\"javascript:window.history.back();\">Document selection</a></p>\n"
+ "<p><a href=\"http://www.scei.co.jp/legal/\">Country / Region selection</a></p>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}