using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b\d{1,2}:\d{2}\b|[,.;:?]+|(?:(?!\b\d{1,2}:\d{2}\b)[^\s,.;:?])+";
string substitution = @"\n$0";
string input = @"Shall we meet at, let's say, 8:45 AM?";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}