import re
regex = re.compile(r"\b\d{1,2}:\d{2}\b|[,.;:?]+|(?:(?!\b\d{1,2}:\d{2}\b)[^\s,.;:?])+")
test_str = "Shall we meet at, let's say, 8:45 AM?"
subst = "\\n$0"
result = regex.sub(subst, test_str)
if result:
print(result)