$re = '/\b\d{1,2}:\d{2}\b|[,.;:?]+|(?:(?!\b\d{1,2}:\d{2}\b)[^\s,.;:?])+/';
$str = 'Shall we meet at, let\'s say, 8:45 AM?';
$subst = "\n$0";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;