const regex = /\b\d{1,2}:\d{2}\b|[,.;:?]+|(?:(?!\b\d{1,2}:\d{2}\b)[^\s,.;:?])+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b\\d{1,2}:\\d{2}\\b|[,.;:?]+|(?:(?!\\b\\d{1,2}:\\d{2}\\b)[^\\s,.;:?])+', 'g')
const str = `Shall we meet at, let's say, 8:45 AM?`;
const subst = `\n$0`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);