re = /\b\d{1,2}:\d{2}\b|[,.;:?]+|(?:(?!\b\d{1,2}:\d{2}\b)[^\s,.;:?])+/
str = 'Shall we meet at, let\'s say, 8:45 AM?'
subst = '\\n$0'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result