import Foundation
let pattern = #"\b\d{1,2}:\d{2}\b|[,.;:?]+|(?:(?!\b\d{1,2}:\d{2}\b)[^\s,.;:?])+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Shall we meet at, let's say, 8:45 AM?"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n$0"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)