using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<!--(.*?)-->|\s\B";
string substitution = @"";
string input = @"<body>
<!-- carousel slider section -->
<section id=""carousel"">
<div class=""carouserl-item"" id=""carousel1"">
<!-- gambar pertama -->
<img src=""img1.jpg"" alt=""Image Description"" width=""300"" height=""600"">
</div>
<div class=""carouserl-item"" id=""carousel2"">
<!-- gambar kedua -->
<img src=""img2.jpg"" alt=""Image Description"" width=""300"" height=""600"">
</div>
</section>
</body>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}