use strict;
my $str = '<body>
<!-- carousel slider section -->
<section id="carousel">
<div class="carouserl-item" id="carousel1">
<!-- gambar pertama -->
<img src="img1.jpg" alt="Image Description" width="300" height="600">
</div>
<div class="carouserl-item" id="carousel2">
<!-- gambar kedua -->
<img src="img2.jpg" alt="Image Description" width="300" height="600">
</div>
</section>
</body>';
my $regex = qr/<!--(.*?)-->|\s\B/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";