# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([+-]?)0+([1-9]\d*)/$1$2/gm;t' <<< "+004200
004200
+00
4200
+4200"