package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([+-]?)0+([1-9]\d*)`)
var str = `+004200
004200
+00
4200
+4200`
var substitution = "$1$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}