$re = '/([+-]?)0+([1-9]\d*)/m';
$str = '+004200
004200
+00
4200
+4200';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;