using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([+-]?)0+([1-9]\d*)";
string substitution = @"$1$2";
string input = @"+004200
004200
+00
4200
+4200";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}