#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([+-]?)0+([1-9]\d*)"
Local $sString = "+004200" & @CRLF & _
"004200" & @CRLF & _
"+00" & @CRLF & _
"4200" & @CRLF & _
"+4200"
Local $sSubst = "$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)