re = /([+-]?)0+([1-9]\d*)/m
str = '+004200
004200
+00
4200
+4200'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result