const regex = /([+-]?)0+([1-9]\d*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([+-]?)0+([1-9]\\d*)', 'gm')
const str = `+004200
004200
+00
4200
+4200`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);