use strict;
my $str = '+004200
004200
+00
4200
+4200';
my $regex = qr/([+-]?)0+([1-9]\d*)/mp;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";