#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "([A-Z0-9]{4})"
Local $sString = "DE12345678901234567890"
Local $sSubst = "$1 "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)