use strict;
my $str = 'DE12345678901234567890';
my $regex = qr/([A-Z0-9]{4})/p;
my $subst = '$1 ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";