import Foundation
let pattern = #"([A-Z0-9]{4})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"DE12345678901234567890"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1 "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)