import re
regex = re.compile(r"([A-Z0-9]{4})")
test_str = "DE12345678901234567890"
subst = "$1 "
result = regex.sub(subst, test_str)
if result:
print(result)