#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)((?:A=|\G)\d):"
Local $sString = "A=1:2:3 B=1:2:3 A=1:2:3:4:5 B=1:2:3"
Local $sSubst = "$1."
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)