use strict;
my $str = 'A=1:2:3 B=1:2:3 A=1:2:3:4:5 B=1:2:3';
my $regex = qr#((?:A=|\G)\d):#mp;
my $subst = '$1.';
my $result = $str =~ s#$regex#$subst#rg;
print "The result of the substitution is' $result\n";