import re
regex = re.compile(r"((?:A=|\G)\d):", flags=re.MULTILINE)
test_str = "A=1:2:3 B=1:2:3 A=1:2:3:4:5 B=1:2:3"
subst = "$1."
result = regex.sub(subst, test_str)
if result:
print(result)