const regex = new RegExp('((?:A=|\\G)\\d):', 'gm')
const str = `A=1:2:3 B=1:2:3 A=1:2:3:4:5 B=1:2:3`;
const subst = `$1.`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);