using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:A=|\G)\d):";
string substitution = @"$1.";
string input = @"A=1:2:3 B=1:2:3 A=1:2:3:4:5 B=1:2:3";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}