import Foundation
let pattern = #"((?:A=|\G)\d):"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"A=1:2:3 B=1:2:3 A=1:2:3:4:5 B=1:2:3"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1."#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)