#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)[A-Z]\d|[^\d\n]+"
Local $sString = "B9966" & @CRLF & _
"ch6258" & @CRLF & _
"028" & @CRLF & _
"chIRZ170" & @CRLF & _
"IRZ170" & @CRLF & _
"" & @CRLF & _
"B9966A1"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)