package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[A-Z]\d|[^\d\n]+`)
var str = `B9966
ch6258
028
chIRZ170
IRZ170
B9966A1`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}