re = /[A-Z]\d|[^\d\n]+/m
str = 'B9966
ch6258
028
chIRZ170
IRZ170
B9966A1'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result