# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[A-Z]\d|[^\d\n]+"
test_str = ("B9966\n"
"ch6258\n"
"028\n"
"chIRZ170\n"
"IRZ170\n\n"
"B9966A1")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.