use strict;
my $str = 'B9966
ch6258
028
chIRZ170
IRZ170
B9966A1';
my $regex = qr/[A-Z]\d|[^\d\n]+/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";