using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[A-Z]\d|[^\d\n]+";
string substitution = @"";
string input = @"B9966
ch6258
028
chIRZ170
IRZ170
B9966A1";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}