const regex = /[A-Z]\d|[^\d\n]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[A-Z]\\d|[^\\d\\n]+', 'gm')
const str = `B9966
ch6258
028
chIRZ170
IRZ170
B9966A1`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);