# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?s)\s*Hello.*world//gm;t' <<< "test 1
Hello
foo
bar
a better world
foo
bar
world
test 2"