re = /(?s)\s*Hello.*world/m
str = 'test 1
Hello
foo
bar
a better world
foo
bar
world
test 2'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result