#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?s)\s*Hello.*world"
Local $sString = "test 1" & @CRLF & _
"Hello" & @CRLF & _
"foo" & @CRLF & _
"bar" & @CRLF & _
"a better world" & @CRLF & _
"foo" & @CRLF & _
"bar" & @CRLF & _
"world" & @CRLF & _
"test 2"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)