$re = '/(?s)\s*Hello.*world/m';
$str = 'test 1
Hello
foo
bar
a better world
foo
bar
world
test 2';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;